Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-71842

Add missing core renderers and clarify deprecation for legacy_format_renderer

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 4.0
    • Fix Version/s: None
    • Component/s: Course
    • Sprint:
      Moppies Kanban

      Description

      In MDL-71135, the course/classes/output/course_format/legacy_renderer.php was added because, since Moodle 4.0, renderer.php file was optional (although highly recommended) for course formats but from Moodle 4.0 onwards renderer is required to support the new course editor implementation.

      This legacy class was created for backward compatibility, to avoid some errors with course formats (such as social) without this renderer.php file.

      This issue has been created to add missing core renderers (i.e. social) and to clarify the deprecation process for this legacy_format_renderer class.
       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              sarjona Sara Arjona (@sarjona)
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: