Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7233

Add support for password change if using Active Directory (with patch).

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7, 1.8, 2.0
    • Fix Version/s: 1.8.1
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      LDAP authentication against Microsoft Active Directory.
    • Affected Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      Currently the LDAP auth backend is only able to change passwords if you are using Novell eDirectory or some OpenLDAP compatible server, but not if using MS Active Directory.

      This patch adds support for that LDAP server. It assumes you have configured a LDAP+SSL connection to your AD server (otherwise AD doesn't allow any operation that modifies the directory) and that you are binding to AD with an account that has the right to reset other users' passwords.

      Saludos. Iñaki.

        Attachments

        1. ad-pwd-expiration-18.diff
          9 kB
        2. ad-pwd-change-19.diff
          1 kB
        3. ad-pwd-change-18.diff
          1 kB
        4. ad-pwd-change-17.diff
          1 kB
        5. ad-pwd-change-16.diff
          1 kB

          Activity

            People

            Assignee:
            skodak Petr Skoda
            Reporter:
            iarenaza Iñaki Arenaza
            Tester:
            Nobody
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Sujith Haridasan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              11/Jun/07