Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7284

ajaxlib may better load the smaler "..--min" YUI files

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1, 1.8
    • Component/s: JavaScript
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      The YUI library comes with readable js files and "...-min" js files. Both are identical in their functionality but the "...-min" files are much smaller. Some are about a quarter in size.

      The "require_js($list)" function loads the normal files, I propose to change the names to the "...-min" ones.

        Attachments

          Activity

            People

            Assignee:
            vyshane Vy-Shane Sin Fat
            Reporter:
            urshunkler Urs Hunkler
            Tester:
            Nobody
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              17/Jan/07