Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-73447

Accented characters (UTF-8) in personal messages are incorrectly rendered in email forwards

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Duplicate
    • 3.9.11, 3.11.4
    • None
    • Email, Messages
    • None
    • MOODLE_311_STABLE, MOODLE_39_STABLE

    Description

      As mentioned in this discussion, personal messages containing international accented characters (with diacritics, UTF-8 encoded) do NOT carry over correctly to the forwarded email copies of these messages.

      Moodle's internal messages interface displays such messages correctly; however, forwarded email copies look corrupted (unencoded?).

      I have tested these languages: Polish and French. I have added screenshots of the test examples tested.

      I have tested directly Moodle versions: 3.9.8 and 3.11.1 (the MoodleCloud site I administer).

      The bug does not affect Moodle 3.6.10.

      Interestingly, the problems appears to ONLY concern the typed contents of personal messages - NOT notifications about Insights or forwards from subscribed forums.  Also the email test message sends correctly. So this file outputs what it should /admin/testoutgoingmailconf.php  , and the Polish language string "testoutgoingmailconf_message" is rendered correctly in the forwarded email of the test message.

      Attachments

        Activity

          People

            Unassigned Unassigned
            pmk Przemek Kaszubski
            Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Stevani Andolo, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Laurent David, Raquel Ortega, Sara Arjona (@sarjona)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: