Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7349

Examview format does not correctly handle XHTML in question/answer text

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.3, 1.7, 1.8
    • Fix Version/s: 1.6.4, 1.7.1, 1.8
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      Examview allows free XHTML between <text> tags. This is not correctly parsed and can cause the text to become corrupted.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              howardsmiller Howard Miller added a comment -

              Certainly one problem in MDL-7333 is caused by <font> tags in the import file being incorrectly parsed and corrupting the input.

              howardsmiller Howard Miller added a comment -

              Data between <text>....</text> tags in Examview XML is now parsed appropriately. Currently all HTML style formatting is simply removed as it mostly appears to be "pseudo" HTML that will only work properly in Examview.


                People

                • Assignee:
                  howardsmiller Howard Miller
                  Reporter:
                  howardsmiller Howard Miller
                  Tester:
                  Nobody
                  Participants:
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    17/Jan/07