Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7447

restoring course from Moodle1.6+ to 1.7+ doesn't work

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not a bug
    • Affects Version/s: 1.7
    • Fix Version/s: None
    • Component/s: Backup
    • Labels:
      None
    • Environment:
      Linux debian stable + MySQL - 5.0.24 backported
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE

      Description

      I try to restore course from a moodle 1.6+ backup course.
      The process is really long. Some time firefox ask me to save the restore.php file
      The course is created but empty : see the screenshot.

      I have no problem with restoration of 1.7 moodle course.

        Gliffy Diagrams

          Activity

          testeur Etienne Rozé created issue -
          stronk7 Eloy Lafuente (stronk7) added a comment -

          Could be possible that something in the restore process without sending data to the browser in a long time will be the culprit for browser timeouts and then, restore fail, Yu?

          Etienne, could you provide us with some numbers about your course? Number of students, modules being used... and if possible, one copy of the course to reproduce the problem in our test environment? (if so, please, send it privately - email).

          Assigning this to Yu.

          stronk7 Eloy Lafuente (stronk7) made changes -
          Field Original Value New Value
          Assignee Eloy Lafuente [ stronk7 ] Yu Zhang [ lazyfish ]
          lazyfish Yu Zhang added a comment -

          Hi,

          It definitely looks like the restore has not finished. How big is your backup file?

          Yu

          testeur Etienne Rozé added a comment -

          Hi,

          Yes. It is a big course with all students data : 268 students and 20 teachers.
          ( I want to restore it on moodle 1.7 to do tests...)
          The backup file size is about 16.3Mo. I 'll try to send you by mail, but it is too big for the moodle mail server.
          I send you a mail with a link for downloading it.

          lazyfish Yu Zhang added a comment -

          Hi,

          During the first few runs we run into memory problems. I have raised memory_limit in php.ini to 1000MB and got pretty far until I got an error saying

          The cloze question 62 is missing its options

          And the script just terminated. Maybe you can take a look at this question and see if there's anything unusual about it.

          You might also need to increase your memory_limit in php.ini since you did not see the error message, so I think you didn't get far.

          Cheers,

          Yu

          testeur Etienne Rozé added a comment -

          Hi,

          Thank you. I got pretty far too with this php configuration. I have the same error message. I continue test.
          Perhaps it's a other ticket.
          Etienne

          lazyfish Yu Zhang added a comment -

          Hi,

          I will close this one then, please open another one and assign it to me once you find out what problem it is.

          Cheers,

          Yu

          lazyfish Yu Zhang made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Not a bug [ 7 ]
          dougiamas Martin Dougiamas made changes -
          Workflow jira [ 18252 ] MDL Workflow [ 54125 ]
          dougiamas Martin Dougiamas made changes -
          Workflow MDL Workflow [ 54125 ] MDL Full Workflow [ 83221 ]
          Subversion JIRA

          Links Hierarchy

           Documentation

          Invalid license: EXPIRED

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: