Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-74566

Images not showing when importing feedback questions

    XMLWordPrintable

Details

    • Bug
    • Resolution: Unresolved
    • Minor
    • None
    • 3.11.7, 4.0
    • Feedback
    • MOODLE_311_STABLE, MOODLE_400_STABLE
    • MDL-74566-master
    • Hide
      1. Add a new Feedback
      2. Add a question of type 'label'
      3. Insert an image in the content field
      4. Save question
      5. Go back to the feedback overview
      6. Click on the cogwheel menu and select 'Export questions' - a xml file is then saved on your computer
      7. Click on the cogwheel and select 'Import questions'
      8. Upload the xml file, select the 'Append new items (All old questions and the assigned values will be preserved)' option and click on 'Save' 
      9. Must be 2 question of type label each of them with image 
      10. Click on the cogwheel and select 'Import questions'
      11. Upload the xml file, select the 'ADelete old items (Current questions and all responses will be deleted.)' option and click on 'Save' 
      12. Must be 1 question of type label with image 
      Show
      Add a new Feedback Add a question of type 'label' Insert an image in the content field Save question Go back to the feedback overview Click on the cogwheel menu and select 'Export questions' - a xml file is then saved on your computer Click on the cogwheel and select 'Import questions' Upload the xml file, select the 'Append new items (All old questions and the assigned values will be preserved)' option and click on 'Save'  Must be 2 question of type label each of them with image  Click on the cogwheel and select 'Import questions' Upload the xml file, select the 'ADelete old items (Current questions and all responses will be deleted.)' option and click on 'Save'  Must be 1 question of type label with image 

    Description

      What happens: When importing questions with images in the feedback activity, the images are not being displayed.

      What is expected: When importing questions, inserted images should also be displayed.

       

      Reproduction steps:

      1. Add a new Feedback
      2. Add a question of type 'label'
      3. Insert an image in the content field
      4. Save question
      5. Go back to the feedback overview
      6. Click on the cogwheel menu and select 'Export questions' - a xml file is then saved on your computer
      7. Click on the cogwheel and select 'Import questions'
      8. Upload the xml file and click on 'yes' (it doesn't matter if you choose to delete old items or to append new items)
      9. Go back to the feedback overview
      10. Make a preview of the feedback
      11. The image is not shown. When you try to open the image in a new tab you will get the following error from moodle: 'Sorry, the requested file could not be found'.

      Attachments

        Activity

          People

            Unassigned Unassigned
            lukaslang Lukas Lang-Kiss
            Stevani Andolo Stevani Andolo
            Amaia Anabitarte Amaia Anabitarte
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:

              Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 2 hours, 30 minutes
                2h 30m

                Clockify

                  Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.