Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7477

Single hyphen in description field of Branch table in lesson module makes button disappear

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Component/s: Lesson
    • Labels:
      None
    • Environment:
      Gentoo - php4
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE

      Description

      Escaping the hyphen (eg J\'ai compris) resolves this but the problem is we have hundreds of these description fields with unescaped single hyphens in them

        Gliffy Diagrams

          Attachments

            Activity

            creole Ned Moltoya created issue -
            bushido Mark Nielsen added a comment -

            Tracked down the problem. Looks like the API changed in lib/weblib.php. I have a bug regarding the API and I'm now waiting for a response before fixing this problem. Here is the bug: MDL-7711

            bushido Mark Nielsen added a comment -

            No feedback from that bug yet. I implemented a quick fix since this is rather severe. Thanks for the report and sorry about the inconvenience.

            bushido Mark Nielsen made changes -
            Field Original Value New Value
            Status Open [ 1 ] Resolved [ 5 ]
            Fix Version/s 1.7.1 [ 10151 ]
            Resolution Fixed [ 1 ]
            dougiamas Martin Dougiamas made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            QA Assignee nobody
            dougiamas Martin Dougiamas made changes -
            Workflow jira [ 18284 ] MDL Workflow [ 54159 ]
            dougiamas Martin Dougiamas made changes -
            Workflow MDL Workflow [ 54159 ] MDL Full Workflow [ 83249 ]

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  17/Jan/07