Moodle
  1. Moodle
  2. MDL-7477

Single hyphen in description field of Branch table in lesson module makes button disappear

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Component/s: Lesson
    • Labels:
      None
    • Environment:
      Gentoo - php4
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE
    • Rank:
      27781

      Description

      Escaping the hyphen (eg J\'ai compris) resolves this but the problem is we have hundreds of these description fields with unescaped single hyphens in them

        Activity

        Hide
        Mark Nielsen added a comment -

        Tracked down the problem. Looks like the API changed in lib/weblib.php. I have a bug regarding the API and I'm now waiting for a response before fixing this problem. Here is the bug: MDL-7711

        Show
        Mark Nielsen added a comment - Tracked down the problem. Looks like the API changed in lib/weblib.php. I have a bug regarding the API and I'm now waiting for a response before fixing this problem. Here is the bug: MDL-7711
        Hide
        Mark Nielsen added a comment -

        No feedback from that bug yet. I implemented a quick fix since this is rather severe. Thanks for the report and sorry about the inconvenience.

        Show
        Mark Nielsen added a comment - No feedback from that bug yet. I implemented a quick fix since this is rather severe. Thanks for the report and sorry about the inconvenience.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: