Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-74808

HTML validator errors on the question bank page

    XMLWordPrintable

Details

    • MOODLE_311_STABLE, MOODLE_400_STABLE
    • MOODLE_400_STABLE
    • MDL-74808-400
    • MDL-74808-master
    • Hide

      You will need to validate some parts of the code on Nu Html Checker

      Checkboxes should only have "checked" attribute

      1. Log in as admin and go to Home > Question bank
      2. Click "Search options" to expand the options.
      3. Check the following checkboxes:
        • Show question text in the question list
        • Also show questions from subcategories
        • Also show old questions
      4. After the page reloads, inspech each checkbox.
      5. Ensure they don't have a checked="checked" or {{checked="true"}}attribute, it should only have a checked attribute on each element.

      Create new question button doesn't has empty title attribute

      1. Inspect the Create a new question... button
      2. Ensure it doesn't have a empty title attribute.

      Element "p" not allowed as child of element "span"

      1. Click Create a new question... button.
      2. Once the question type choose opens, click in any of the question types.
      3. Inspect the question type description text.
      4. Ensure the question type text is enclosed by a <div> tags instead of <span>.
      5. Ensure that div is not enclosed by a <label>.
      6. Copy the whole div content <div class="option selected"... and validate on the Nu Html validator.
      7. Ensure no validation errors are displayed.

      Question tags are not inside the question label

      1. Add a new question, setting a couple of tags in the form.
      2. Once the question is created, inspect the question's name.
      3. Ensure the <label> has only the question text in it (no other html code).
      4. Inspect the question tags.
      5. Ensure they are not enclosed by the <label>
      Show
      You will need to validate some parts of the code on Nu Html Checker Checkboxes should only have "checked" attribute Log in as admin and go to Home > Question bank Click "Search options" to expand the options. Check the following checkboxes: Show question text in the question list Also show questions from subcategories Also show old questions After the page reloads, inspech each checkbox. Ensure they don't have a checked="checked" or {{checked="true"}}attribute, it should only have a checked attribute on each element. Create new question button doesn't has empty title attribute Inspect the Create a new question... button Ensure it doesn't have a empty title attribute. Element "p" not allowed as child of element "span" Click Create a new question... button. Once the question type choose opens, click in any of the question types. Inspect the question type description text. Ensure the question type text is enclosed by a <div> tags instead of <span> . Ensure that div is not enclosed by a <label> . Copy the whole div content <div class="option selected"... and validate on the Nu Html validator. Ensure no validation errors are displayed. Question tags are not inside the question label Add a new question, setting a couple of tags in the form. Once the question is created, inspect the question's name. Ensure the <label> has only the question text in it (no other html code). Inspect the question tags. Ensure they are not enclosed by the <label>
    • 1
    • Team Omega 4.1 Sprint 0.1

    Description

      When running the Nu HTML validator on the question bank page source, we get the following:

      Errors
      1. Bad value "true" for attribute checked on element "input"
        • Found in "Search options" checkboxes ("Also show questions from subcategories", "Also show old questions"
      2. Duplicate attribute "title"
        • The error seems to point to the "Create a new question..." button with an empty title attribute.
      3. Element "p" not allowed as child of element "span" in this context.
        • This points to the question chooser where the description for the question type plugin is being enclosed in <p> tags when the container of the question type description in the template is in a <span> tag.
      4. Element "div" not allowed as child of element "label" in this context.
        • This is due to the question tags which are enclosed in <div> tags within the question <label> element.

      Attachments

        1. 1_MDL-74808_master.png
          1_MDL-74808_master.png
          141 kB
        2. 1_MDL-74808_v400.png
          1_MDL-74808_v400.png
          232 kB
        3. 2_MDL-74808_master.png
          2_MDL-74808_master.png
          193 kB
        4. 2_MDL-74808_v400.png
          2_MDL-74808_v400.png
          261 kB
        5. 3_MDL-74808_master.png
          3_MDL-74808_master.png
          62 kB
        6. 3_MDL-74808_v400.png
          3_MDL-74808_v400.png
          62 kB
        7. 4_MDL-74808_master.png
          4_MDL-74808_master.png
          83 kB
        8. 4_MDL-74808_v400.png
          4_MDL-74808_v400.png
          127 kB

        Activity

          People

            lameze Simey Lameze
            jpataleta Jun Pataleta
            Shamim Rezaie Shamim Rezaie
            Jun Pataleta Jun Pataleta
            John Edward Pedregosa John Edward Pedregosa
            Safat Shahin, Tim Hunt, Ilya Tregubov, Kevin Percy, Mathew May, Mihail Geshoski, Shamim Rezaie
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              22/Aug/22

              Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 2 days, 1 hour, 36 minutes
                2d 1h 36m