Moodle
  1. Moodle
  2. MDL-7540

Canot access means to create new course when assigned as a course creator

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Component/s: Administration, Course
    • Labels:
      None
    • Environment:
      phph 5.1.1 mySQL 4.0.18 XP
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE
    • Rank:
      27774

      Description

      On my test Moodle I have a user assigned at site level as Course Creator and Teacher - the roles are unmodified.

      Whilst logged in as this user, when I turn editng on at site level the administration block (when expanded) is empty. In 1.6.x this displayed a "Courses" link to http://mysite/moodle/course/index.php.

      I can access http://mysite/moodle/course/index.php by typing the address but how can I get the "Course" link to show as before, alteratively what is the replacement mechanism to allow those allocated as Course Creators to access the Create new course button?

      This site is an upgrade from 1.6.1.

      There is no link in either the Administration or site Administration blocks.

        Activity

        Ned Moltoya added a comment -

        We have the following setup: all our language teachers have the roles of (editing) teacher at the site level and of course creator in the course category of the language they teach. However, they can't create new courses in this category (the button doesn't appear). Upgrade from 1.6.3

        Dan Poltawski added a comment -

        I've just reproduced the category bug.

        Assign a user course creator at category context and they seem not to get the add new course link, when going to that category page.

        Dan Poltawski added a comment -

        There seems to be a lot of misused contexts in the category page, for some reason site level is used all over the place. I don't understand why the category context isn't used, but maybe i'm missing something.

        Yu Zhang added a comment -

        Hi,

        To access course categories, you can put a "Courses" block on the main page. Then you will either see a course categorhy listing, or you can click on the all courses link, and be able to access the individual course categories.

        The confusing about the system contexts being abused is all my fault. I thought course creation is always at system level. Fixed according to the patch and added some code to make it possible to create a course from a category link. Thanks for the patch!!!

        Note that default course creators do not come with a course category update capability, so they will only be able to create courses within a category, unless you change the default value.

        Cheers,

        Yu

        John Isner added a comment -

        I'm not sure why this issue is marked "resolved." Unless the administrator adds a Courses block or displays a Combo list on the front page, Course creators will be unable to access their categories. OK, maybe some of them know the magic URL http://yoursite/moodle/courses/index.php. This is still causing confusion among course creators. The appearance of the front page should be orthogonal to whether or not there are course creators.

        How about displaying a list of categories in a course creator's profile? Or a minimal Site administration block for Course creators?


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: