Moodle
  1. Moodle
  2. MDL-7546

The grades page is only listing site wide admin users; students enrolled on the course are not on the list.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Component/s: Gradebook
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE
    • Rank:
      27770

      Description

      The grades page is only listing site wide admin users; students enrolled on the course are not on the list. This means that students cannot view their grades and teachers cannot review student grades.

      The specific URL in question is:
      http://www.mymoodlesite/grade/index.php?id="courseidnumber"

      Marty

        Activity

        Hide
        Dan Poltawski added a comment -

        Verified this and upgrading priority of this as it seems quite nasty..

        Show
        Dan Poltawski added a comment - Verified this and upgrading priority of this as it seems quite nasty..
        Hide
        Dan Poltawski added a comment -

        This appears to be related to the gradebookroles variable defaulting to 5.

        My mysql server uses auto_increment_increment and so the id for the student role is not 5, indeed a role with id 5 doesn't exist.

        Show
        Dan Poltawski added a comment - This appears to be related to the gradebookroles variable defaulting to 5. My mysql server uses auto_increment_increment and so the id for the student role is not 5, indeed a role with id 5 doesn't exist.
        Hide
        Dan Poltawski added a comment -

        Hmm I can't work out where that setting got set.

        Marty: If you go to admin->appearance->graderoles and define roles which can be shown, does it fix the issue?

        Show
        Dan Poltawski added a comment - Hmm I can't work out where that setting got set. Marty: If you go to admin->appearance->graderoles and define roles which can be shown, does it fix the issue?
        Hide
        Yu Zhang added a comment -

        Hi,

        This should already have been fixed, you having this problem probably because you upgraded to 1.7 before it was fixed. Please note the new setting =)

        Cheers,

        Yu

        Show
        Yu Zhang added a comment - Hi, This should already have been fixed, you having this problem probably because you upgraded to 1.7 before it was fixed. Please note the new setting =) Cheers, Yu

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: