Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a bug
    • Affects Version/s: 1.6.2
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None
    • Environment:
      All
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Rank:
      8918

      Description

      Users (instructors and students) are complaining that the courses under My Courses are not in alphabetic order.

      Also the creators and admins find very difficult to check what users are enrolled in a course because

      NOTHING IS IN ALPHABETIC ORDER!

      The question is how difficult would be to do this?

      We cannot find a good explanation on how the courses under My Courses are displayed. Obviously they are not alphebitized but also they do not seem to follow any other logic from top to bottom. When we add a new courses, we thought it would be at the bottom of the list but it is not!

      Is there any good reason why this cannot be done and help people find things easier?

        Activity

        Beatriz Beltran added a comment -

        Does anybody check these requests? It has been a long time since I reported this problem and not even a comment?

        Beatriz Beltran added a comment -

        Moodle is the best possible LMS that I have worked with. It is my intention to make the users of the Moodle site I work with to see how good this system is. 99% of the users have never seen any LMS before so any single reason for not to use it, as the courses not in alphabetic order, is a motive for complain.

        Help me to make them like Moodle as I do, please.

        Anthony Borrow added a comment -

        Beatriz - I too am a Moodle fan! Sometimes it can be helpful to raise these types of issues on the Using Moodle forums where more users are likely to see it, get involved and offer feedback. The tracker is primarily seen by developers and those reporting bugs and suggestions for improvement. Someone will see it; however, it may not be seen as a priority and since fewer folks are seeing it then fewer have the chance to respond. A couple of questions. Are you aware of the re-sort by course name button on the /course/category.php page? By default, students are sorted by last access; however, you can click on the lastname link at the top of the column and it will sort them by last name or firstname. Hopefully these tips will help you to help your users to find what they need. Let me know if you have any questions. Peace - Anthony

        Anthony Borrow added a comment -

        MartinD - I believe that the functionality being requested in this issue is already present in Moodle. While there are some places where I have customized Moodle to sort by lastname, firstname rather than firstname, lastname. I prefer to see names as firstname lastname but often want them sorted lastname, firstname. I think this idea of separating the display of a name from the way it is sorted will depend to a large degree on how the various modules are written and separating them might be nice but I think that is a separate request/suggestion. With that said, I believe that this particular issue is NOT A BUG and think that it could be CLOSED. Peace - Anthony

        p.s. This issue is partially or somewhat related to MDL-7163.

        Brian Pool added a comment -

        I agree with the fact that the "My Moodle" Page should be alphabetical by course. Has anyone written a fix for this?

        Anthony Borrow added a comment -

        As I have gone back and looked at this issue - I see it is initially raised as being related to the My Courses block. I'm not sure how courses are sorted but it would be good to make it clear what the method to the madness is. I'll see if I can investigate this and see what is happening. Should there be an option for how to sort the courses in the My Courses block or on the My Moodle page. Should this be a site or user defined preference? Peace - Anthony

        Andrew Davis added a comment -

        The courses are displayed according to their "sort order". Determining the sort order can be a little complex but there is definitely a method.

        If you go to Courses -> Add/edit courses you will get a list of course categories. You can use the up and down arrows next to each category to arrange the order of the categories. My Courses will display all the courses in the first category then all the courses in the second category and so on.

        Clicking on any category will take you to a list of the courses in that category. These can be reordered using the arrows in the same way as the categories. This page determines the order the courses are displayed in within the category.

        As Anthony Borrow mentioned there is also a "Re-sort courses by name" button on this page that sorts the courses within the category alphabetically.


          People

          • Votes:
            3 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: