Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-76020

Some items missing from footer in Classic theme

    XMLWordPrintable

Details

    • MOODLE_400_STABLE
    • MOODLE_400_STABLE
    • MDL-76020-master
    • Hide
      1. Log in as admin.
      2. Switch your site's theme to Classic (Site administration > Appearance > Themes > Theme selector, in Default choose change theme and Use theme for Classic).
      3. Scroll to the bottom of the page and CONFIRM that above the "You are logged in as" line, you see the following (in order):
        • Help and documentation
        • Services and support
        • Contact site support
      4. Follow each of the links and CONFIRM they take you to the expected location (if you are unsure, you can switch to Boost theme and compare the results with the equivalent links in the "?" footer popover).
      5. Log out and log in as a student.
      6. CONFIRM you see the "Contact site support" link, but do not see the other 2 links.
      Show
      Log in as admin. Switch your site's theme to Classic ( Site administration > Appearance > Themes > Theme selector, in Default choose change theme and Use theme for Classic). Scroll to the bottom of the page and CONFIRM that above the "You are logged in as" line, you see the following (in order): Help and documentation Services and support Contact site support Follow each of the links and CONFIRM they take you to the expected location (if you are unsure, you can switch to Boost theme and compare the results with the equivalent links in the "?" footer popover). Log out and log in as a student. CONFIRM you see the "Contact site support" link, but do not see the other 2 links.
    • 1
    • Team Hedgehog 4.1 sprint 0 rev

    Description

      When some new items were added to the footer in 4.0, they were not also applied to the classic footer (which was split off into its own template in 4.0 as well).

      "Help and documentation" already exists, however the following are missing:

      • Services and support
      • Contact site support

      This needs to be backported to 4.0 as well as a bug, because currently that includes the contact site support functionality/form (and support email is mandatory), but there is no way to navigate to it in the UI.

      Attachments

        1. MDL-76020_master_1.png
          MDL-76020_master_1.png
          121 kB
        2. MDL-76020_master_2.webm
          1.44 MB
        3. MDL-76020_master_3.png
          MDL-76020_master_3.png
          123 kB
        4. MDL-76020_v400_1.png
          MDL-76020_v400_1.png
          117 kB
        5. MDL-76020_v400_2.webm
          1.87 MB
        6. MDL-76020_v400_3.png
          MDL-76020_v400_3.png
          95 kB

        Issue Links

          Activity

            People

              michaelh Michael Hawkins
              michaelh Michael Hawkins
              Huong Nguyen Huong Nguyen
              Sara Arjona (@sarjona) Sara Arjona (@sarjona)
              Angelia Dela Cruz Angelia Dela Cruz
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 3 hours, 45 minutes
                  3h 45m

                  Clockify

                    Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.