Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7674

change YUI loading function

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.1
    • Fix Version/s: 1.7.1, 1.8
    • Component/s: JavaScript
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      The actual "require_js()" function is restricted to a sublist of hard coded YUI files. When I need for example "animation" I either must hack "ajax.php" or use my own loading script.

      The "$translatelist = array(" should always reflect the whole YUI library.

        Attachments

          Activity

            People

            Assignee:
            moodle.com moodle.com
            Reporter:
            urshunkler Urs Hunkler
            Tester:
            Andrew Davis
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              17/Jan/07