Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-7684

Not finding / running msmanifest.xml files

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not a bug
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7
    • Component/s: SCORM
    • Labels:
      None
    • Environment:
      Moodle 1.7, Mysql 4.1.20, php 4.3.11, Linux / Apache 1.3.31 Unix,
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE

      Description

      ===The following is my report from within the Moodle forums === next a follow up ===

      In my situation the scorm 1.2 packages I create in both eXe and Reload are also not being seen in 1.7 with the following symptions:

      After creating six scrom 1.2 packages in eXe-019 and two in Reload 2.0.2 and then uploading, the Moodle 1.7 version couldn't find the imsmanifast.xml file 90% of the time. In other words, I tried to access the created scorm files 10 times and I was only able to get Moodle 1.7 to run / connect properly once. The testing took me over two hours to complete. I've done seven test in 1.6 and all worked fine. The two versions of Moodle I run are on the same box. So it does look like there is a problem with the scorm module or / and 1.7. I'll try to report this as well as I can so it could be corrected.

      Now with 1.7 when it connects with the imsmamifest.xml it will continue to run correctly. However, this may be after to 20th time trying to connect.

      ========================
      More on this issue: I should also note that after trying to view a scrom 1.2 package the "Course structure" is not shown on the first page. When the "Course structure is shown the scorm 1.2 loads fine.

        Attachments

        1. exetest5e.zip
          290 kB
        2. exetest5f.zip
          208 kB

          Activity

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                7/Nov/06