Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-78172

Multilang filter is not applied in forum groups

XMLWordPrintable

    • MOODLE_401_STABLE, MOODLE_402_STABLE
    • MOODLE_401_STABLE, MOODLE_402_STABLE
    • MDL-78172-401
    • MDL-78172-402
    • Hide
      1. Log in as admin
      2. Navigate to Plugins > Filters > Manage filters in site administration
      3. Enable Multi-language content
        • Apply to: Content and headings
      4. Create a course
        • Group mode: Visible groups
      5. Create a group named:

        <span class="multilang" lang="en">Group (EN)</span><span class="multilang" lang="de">Group (DE)</span>
        

      6. Add yourself to the created group
      7. Navigate to course Announcements forum
      8. Amend activity settings:
        • Group mode: Visible groups
      9. On forum page, set Visible groups: All participants
      10. Press Add discussion topic
      11. Press Advanced
      12. Confirm the Group select contains correctly formatted "Group (EN)" option
      13. Select "Group (EN)"
      14. Add a subject & message and post to forum
      15. Confirm the Group column of the discussion list contains correctly formatted "Group (EN)"
      16. Press Reports to access the forum summary report
      17. Press Groups button to open filter
      18. Confirm the popup contains correctly formatted "Group (EN)" option
      Show
      Log in as admin Navigate to Plugins > Filters > Manage filters in site administration Enable Multi-language content Apply to: Content and headings Create a course Group mode: Visible groups Create a group named: <span class="multilang" lang="en">Group (EN)</span><span class="multilang" lang="de">Group (DE)</span> Add yourself to the created group Navigate to course Announcements forum Amend activity settings: Group mode: Visible groups On forum page, set Visible groups: All participants Press Add discussion topic Press Advanced Confirm the Group select contains correctly formatted "Group (EN)" option Select "Group (EN)" Add a subject & message and post to forum Confirm the Group column of the discussion list contains correctly formatted "Group (EN)" Press Reports to access the forum summary report Press Groups button to open filter Confirm the popup contains correctly formatted "Group (EN)" option

      I've found a couple of instances in the forum where group names are rendered without applying the multilang filter. In particular:

      • Group column in the discussions table (group mode has to be set to "Visible groups" in the forum settings in order to see this column).
      • Group name in the title of the group image in forum posts (this is the image under the user avatar).

        1. MDL-78172.png
          474 kB
          Ron Carl Alfon Yu

            pholden Paul Holden
            noeldemartin Noel De Martin
            Andrew Lyons Andrew Lyons
            Mihail Geshoski Mihail Geshoski
            Ron Carl Alfon Yu Ron Carl Alfon Yu
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Created:
              Updated:
              Resolved:

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour, 29 minutes
                1h 29m

                  Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.