Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-78421

Moodle fails to upgrade

    XMLWordPrintable

Details

    • Bug
    • Resolution: Not a bug
    • Minor
    • None
    • 4.2
    • Installation
    • None
    • MOODLE_402_STABLE

    Description

      We have a 4.1.3 + (Build: 20230602) we are trying to upgrade to 4.2.  We have uninstalled Assignment 2.2 and removed the directories from the disk and the Site Administrator -> Server -> Environment -> checks all show OK.  We use git to retrieve MOODLE_402_STABLE and that shows no errors or issues. With debugging on, when we access the server to complete the upgrade we get Fatal error: Cannot override final method core_courseformat\base::get_context() in /srv/www/htdocs/moodle/course/format/topcoll/lib.php on line 1715.  but never get the option to update the database or to pull the compatible versions of the plugins down.  

      SLES 15 SP4

      PHP 8.0.28

      Attachments

        Activity

          People

            Unassigned Unassigned
            vdiscipio Vincent T DiScipio
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Clockify

                Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.