Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-79209

Course index: collapse all sometimes not working when only 1 section is expanded

    XMLWordPrintable

Details

    • MOODLE_403_STABLE

    Description

      The first time it happened to me was in one of our internal testing sites, using Chrome. Then I tried in qa.moodledemo.net as teacher, also with Chrome, and it happened too. Then I tried again in qa.moodledemo.net as teacher but using Firefox and it happened too. I'm attaching a video recording of what happened.

      I tried again after doing the video recording and I wasn't able to reproduce it, so it seems it only happens some times or under certain conditions.

      What I did is:

      1. Login in qa.moodledemo.net with teacher/moodle.
      2. Open Activity examples course.
      3. In course index, open the kebab menu and click Collapse all.
      4. Expand 'Assignments' section in course index. I think I clicked in the arrow at the left, not in the name (so the section was not selected in the main pane).
      5. Open the kebab menu and click Collapse all. The section was collapsed.
      6. Now expand 'Chats' section. Again, I think I clicked in the arrow, not in the name.
      7. Open the kebab menu and click Collapse all. The section does NOT collapse.
      8. After this, if I expand other sections they're collapsed when I click Collapse all, but the one that is failing continues to be expanded.

       

      Attachments

        Issue Links

          Activity

            People

              jleyva Juan Leyva
              dpalou Dani Palou
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:

                Clockify

                  Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.