Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8013

SCORM module fails importing eXe created packages

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Not a bug
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7
    • Component/s: SCORM
    • Labels:
      None
    • Environment:
      Fedora 5.0, MySQL 5, PHP 5.1.
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE

      Description

      When importing eXe created packages into Moodle 1.7+ SCORM module, a popup windows apperas with the message "Validation result:". Clicking the OK button in the popup windows, Moodle displays the message "There are some problems with the given package. Check it and try again."

      The very same SCORM package (attached) works flawlessly in Moodle 1.6.x.

      eXe version is 0.19.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              upo Roberto Pinna added a comment -

              It works for me.
              The problem seems to be a bug in phpzip library in Moodle 1.7.
              If you use the system command (/usr/bin/unzip) it works without problem.

              I will add a test in scorm activity creation to give a better error message.

              Bobo.

              danmarsden Dan Marsden added a comment -

              closing this - Andrea, we're still in need for more SCORM objects in the SCORM repository here:
              http://moodle.org/mod/data/view.php?id=7198

              would you mind adding the object attached to this bug into the repository?

              thanks!

              Dan


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    7/Nov/06