Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8031

Enforce password complexity for user Authentication

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6.3
    • Fix Version/s: 1.9
    • Component/s: Authentication
    • Labels:
      None
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Currently, there is no way to enforce password complexity requirements. Iñaki has submitted a diff file that implements this functionality. If possible, I would like to see this improvement added to version 1.8 (if it is considered a new feature) or perhaps added to 1.6+ and 1.7 if it is considered an improvement to the existing authentication. I am attaching Iñaki's diff file for version 1.6.3+.

        Attachments

        1. password-policy.diff
          7 kB
        2. password-policy-16.diff
          6 kB
        3. password-policy-17.diff
          6 kB
        4. password-policy-17.diff
          6 kB
        5. password-policy-18dev.diff
          6 kB
        6. password-policy-18dev.diff
          6 kB

          Issue Links

            Activity

              People

              Assignee:
              skodak Petr Skoda
              Reporter:
              aborrow Anthony Borrow
              Tester:
              Nobody
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              3 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                3/Mar/08