Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8067

theme does not work when editing profile while using https

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.4, 1.6, 1.6.1, 1.6.2, 1.6.3, 1.7, 1.8
    • Fix Version/s: 1.8
    • Component/s: Administration, Themes
    • Labels:
      None
    • Environment:
      Red Hat Enterprise, Apache 1.3.37, PHP 4.4.4, MySQL 4.1.21
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_15_STABLE, MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      I have enabled https after installing an SSL certificate. The login page works correctly after changing the tags which call the graphics from <?php echo $CFG->wwwroot.'/theme/'.current_theme() ?> to <?php echo $CFG->httpswwwroot.'/theme/'.current_theme() ?>.

      However, this fix does not work when I go to edit my profile. The site attempts to go to the edit page using the https address and both IE and FireFox give a notice that there are unsecured items on the page. The unsecure items are the entire theme. If you choose to not display the unsecure items in IE, there is absolutely no formatting or graphics.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                skodak Petr Skoda
                Reporter:
                jwatkins Jeffery Watkins
                Tester:
                Nobody
                Participants:
                Component watchers:
                Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Bas Brands
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  31/Mar/07