Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8100

question XML import does not respect defaultgrade value

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6.3, 1.6.4, 1.7, 1.7.1, 1.7.2, 1.8
    • Fix Version/s: 1.7.1, 1.8
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      XML format of a question includes <dafaultgrade> option.
      It gets correctly exported from moodle. For example:
      <defaultgrade>3</defaultgrade>
      However, the same exported file in import does not take into account its value and substitues it with 1. This is a serious problem when importing a large number of questions into moodle - it is very time consuming.

        Gliffy Diagrams

          Activity

          Hide
          howardsmiller Howard Miller added a comment -

          Fixed in CVS. Stupid mistake, question object initialization and reading of value the wrong way around. Whoops!

          Thanks for spotting this one.

          Show
          howardsmiller Howard Miller added a comment - Fixed in CVS. Stupid mistake, question object initialization and reading of value the wrong way around. Whoops! Thanks for spotting this one.
          Hide
          fikar Miroslav Fikar added a comment -

          Hi Howard,
          thanks, it is working now. Could you please fix it also in 1.6.3+?
          Miro

          Show
          fikar Miroslav Fikar added a comment - Hi Howard, thanks, it is working now. Could you please fix it also in 1.6.3+? Miro

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                17/Jan/07