Moodle
  1. Moodle
  2. MDL-8137

form autocomplete bug (previously MDL-4423)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.2
    • Component/s: Lesson
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE
    • Rank:
      29324

      Description

      This bug is identical to the one originally posted and closed as MDL-4423 (autocomplete was not set to "off," displaying previous answers under the text box) ; the difference is that only the quiz module was fixed, not other modules using a form. I have not looked into all of the source, but I caught this bug in the lesson module. The form is located on line 564 of /mod/lesson/view.php.

        Activity

        Hide
        Mark Nielsen added a comment -

        Thanks for this bug report. I was wondering how to fix this problem.

        I added autocomplete="off" for the following forms:

        In view.php:

        • Password form (don't think it was really needed, but for consistency)
        • Student answer form

        In highscores.php

        • Nickname form

        Cheers and thanks,
        Mark

        Show
        Mark Nielsen added a comment - Thanks for this bug report. I was wondering how to fix this problem. I added autocomplete="off" for the following forms: In view.php: Password form (don't think it was really needed, but for consistency) Student answer form In highscores.php Nickname form Cheers and thanks, Mark
        Hide
        Pete Stucke added a comment -

        My pleasure, happy to help.

        Show
        Pete Stucke added a comment - My pleasure, happy to help.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: