Moodle
  1. Moodle
  2. MDL-8227

Wiki - locking facility applies to all groups not just the one being edited

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7, 1.7.1, 1.8
    • Fix Version/s: 1.7.3, 1.8
    • Component/s: None
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      While you edit a wiki page e.g. one called 'Frog', it is locked and nobody else can edit it. This is intended behaviour.

      However if you are on a group wiki and you try to edit a page called 'Frog' while somebody else in a separate group is editing their own page called 'Frog', it won't let you, even though it should!

        Gliffy Diagrams

          Issue Links

            Activity

            Sam Marshall added a comment -

            This was caused by storing the wrong ID in the lock table - it used the wiki id, not the wiki_entries id. I have changed the code to do that

            Martin Dougiamas added a comment -

            See linked bug for more details ... a lot of people are having problems with this.

            Sam Marshall added a comment -

            I applied the patch to 1.7 and it seems to do the job. (I tested before/after).


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: