Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8342

Import of Blackboard5 questions failing (quiz with 110 questions- mixture of true-false, multiple-choice, and fill-in-the-blank

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.4, 1.7.1
    • Fix Version/s: 1.7.2, 1.8
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      PHP 5.1.6 Mysql 5.0.27 Apache 2.0 on Fedora Core 5 server
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      Export a 110 item test from Examview 5.1.1 to BB5 format (zip file) (test and exported bb5 zipfile attached)
      To reproduce the problem:
      unzip the exported zip file
      attempt to import the res0000.dat file

      Moodle 1.7.1
      returns a blank screen after ~15 seconds

      Moodle 1.6.4
      reports
      Fatal error: Using $this when not in object context in /var/www/moodle/moodle-1.6.4/question/format/blackboard/format.php on line 89

      The problem didn't occur with a smaller test (a simple 12 question test with 2 tf and 10 multiple choice
      Examview test also attached along with zipfile of exported data

      MY SOLUTION - see attached format.php that has been working fine for me for both 1.7.1 and 1.6.4 versions

        Gliffy Diagrams

        1. t2.tst
          578 kB
          Arthur Manning

          Activity

          howardsmiller Howard Miller added a comment -

          This seems to be PHP5 related. A line that uses @... to workaround optional data in the XML file was causing the hang. Additional check code added.

          Fixed in CVS.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                30/Mar/07