Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8414

Branch table buttons in incorrect order

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.8.1
    • Component/s: Lesson
    • Labels:
      None
    • Environment:
      Rays = xp, mysql 5.018, php 5.1.1
      Chris is similar
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      When creating a simple branch table the resulting buttons are displayed in the incorrect order (whether vertically or horizontally aligned). In Ray's 1.7 and Chris's 1.8.

      Example: Descriptions in this order..

      1Jump to next page,.
      2Jump to specified page
      3End of Lesson

      Displayed as:

      2Jump to specified page
      3End of Lesson
      1Jump to next page,

        Gliffy Diagrams

          Activity

          rcollman Chris Collman added a comment -

          It is inconsistant. Just noticed this myself. Description 1-5 in edit mode ended up in vertical order as 2,3,4,5,1 in the example page I was working in. Yet in another page Decription 1-3 ended up in 1,2, 3..

          Did a page refresh, exited, cleared history and returned. This happened on my local host 1.8 that I just updated today 5 Arpril with the latest and greatest Moodle. I had just suggested the student go through the lesson in the order of the buttons below. Ooops! Never noticed this before.

          bushido Mark Nielsen added a comment -

          Just committed a fix for 1.8.1. If you could verify by downloading a freshly packaged 1.8+ or by checking out MOODLE_18_STABLE that would be great (Ray or Chris or both!).

          This was caused by some background "wizardry" and it was intentional. This was done some time ago and now just does not make any sense. I removed it from the code and things are much more simple

          Cheers,
          Mark

          ray Ray Lawrence added a comment -

          Hi,

          Just tried it. All seems fine.

          Cheers


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Jun/07