Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8425

some not W3C html validator compliant pages

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8
    • Component/s: Accessibility
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      I listed some some not W3C html validator compliant pages in mediatouch Moodle 18 testing site.
      Password is needed to get inside the site but you (Martin) have it and you can check them directly.

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            Can you cut and paste the text here, please?

            daniss Daniele Cordella added a comment - - edited

            Yes, of course but links are pointing mtouch installation.

            check the page <br />

            [Martin D deleted some links here to prevent this looking like spam]....

            daniss Daniele Cordella added a comment - - edited

            I am sorry!

            [Martin D deleted some links here to prevent this looking like spam]....

            daniss Daniele Cordella added a comment -

            Congratulation
            As far as I know
            all is right now except

            http://www.mtouch.it/mdl18/mod/wiki/index.php?id=3
            http://www.mtouch.it/mdl18/theme/index.php

            Congratulation.
            Be carefull...
            I tested it with a two days old installation... so maybe the situation is better.
            I can't update the site with the lates release. I am not the owner.

            In any case... thank you.

            daniss Daniele Cordella added a comment -

            No, the pages
            moodle18/mod/wiki/index.php?id=2
            moodle18/theme/index.php
            in a just downloaded copy of moodle don't pass the w3c validation.

            daniss Daniele Cordella added a comment -

            This bug issue was not completed.
            Still two pages are breaking strict.
            If I can ask for an account as course creator in http://test.moodle.com (or whereever you prefer on a shared web site) I can reproduce the pages breaking xhtml strict.

            lazyfish Yu Zhang added a comment -

            Hi Daniele,

            For the theme page to be xhtml strict you need to have the screen reader flag set under your user profile.

            The other problem is actually caused by the HTML editor putting the <p> tag at the beginning of the wiki description. If you don't use the HTML editor for the wiki description, you will not get the error. And I am not sure what we can do about the HTML editor.

            Adding Martin as a watcher.

            Cheers,

            Yu

            daniss Daniele Cordella added a comment -

            > For the theme page to be xhtml strict you need to have the screen reader flag set under your user profile.

            I disagree.
            The page has to be strict without care what I set. I hope you agree with me.

            > And I am not sure what we can do about the HTML editor.
            Ok. We will postpone the solution to the day we will manage the HTML editor.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  31/Mar/07