Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8441

Hidden assignment roles not hidden

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.8
    • Fix Version/s: None
    • Component/s: Roles / Access
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE

      Description

      Users with a hidden assignment teacher role are listed as teachers in the course description and are also listed as teachers on the course participants page.

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            Hi, Helen!

            Yu, can you check this? I thought this came up before and it was working. Vy may know something about it too.

            lazyfish Yu Zhang added a comment -

            Hi Helen,

            People with viewhiddenassigns capabilities should be able to see them, I think, i.e. admins, etc.
            Also, could you please check if these users have got the teachers role assigned at a higher level, i.e. system or course category level?

            Thanks,

            Yu

            tsala Helen Foster added a comment -

            Hi Yu,

            Thanks for your explanation. I now realise everything is working fine I've added a note in the documentation http://docs.moodle.org/en/Assign_roles

            Just wondering whether users with hidden assignment roles could be displayed in grey for users with viewhiddenassigns capabilities?

            tsala Helen Foster added a comment -

            Closing, as not a bug


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: