Moodle
  1. Moodle
  2. MDL-8491

Feedback for essay type questions is not backed up

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.4
    • Fix Version/s: 1.6.5, 1.7.2, 1.8, 1.9
    • Component/s: Backup
    • Labels:
      None
    • Environment:
      PHP 4.4.2, MySQL 4.1.18
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      A client of mine is starting to use essay question types in his moodle quizzes. He has found that when he takes a backup of this (either just the quiz or the whole course, makes no difference) and then tries to restore the quiz (or course) the feedback that had been put in for the essay questions is not restored.

      It might help if someone could tell me which table essay question feedback is stored in, so I can look in the moodle.xml file in the backup and see if it is actually stored, as I don't know if the problem is at the backup stage or the restore stage.

      cheers

      Sean K

        Gliffy Diagrams

          Issue Links

            Activity

            Eloy Lafuente (stronk7) added a comment -

            reassigning to Tim

            Michael Blake added a comment -

            Tim, can you take a look at this. This bug is impacting one of Sean Keogh's clients. Thanks.

            Yu Zhang added a comment -

            Hi,

            This should be fixed in 1.6, 1.7, 1.8 and 1.9 now, thanks for the report,

            Yu


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: