Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8515

Prefixing text with a slash character suppresses username in chat.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6, 1.7
    • Fix Version/s: 1.6.5, 1.7.2, 1.8
    • Component/s: Chat
    • Labels:
      None
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      A Moodle user, Ross Hendricks, reported the problem in this thread:

      http://moodle.org/mod/forum/discuss.php?d=64830#292099

      If chat participants prefix their comment in chat with a slash character, their name is not displayed (this appears to be due to /whatever being treated as a special case, as with /me). Apparently some of his students are using this for annoyance purposes.

      I posted a possible fix in that thread as well, but it was a quick one-off. There may be better ways of dealing with the issue.

        Attachments

          Activity

            People

            Assignee:
            pj Jon Papaioannou
            Reporter:
            tonyhursh Tony Hursh
            Tester:
            Nobody
            Participants:
            Component watchers:
            Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              30/Mar/07