Moodle
  1. Moodle
  2. MDL-8557

Installation - » shown instead of desired » after config.php saved

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8, 1.9
    • Component/s: Installation
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Rank:
      29152

      Description

      » shown instead of desired » after config.php saved

      when » is passed to the print_single_button as the $label the print_single_button calls the s function and transforms the » to &;raquo; causing the incorrect display. The s function is beyond my level of incompetence so I am not sure of the fix but something different needs to be passed to get the intended Continue » to display in the button. I am attaching a jpg of the continue button as it is appearing. I am installing on WinXP, PHP 5.2, Apache 2.2, MySQL 5.x.

        Issue Links

          Activity

          Anthony Borrow added a comment -

          Let me clarify that this is caused by the code in the install.php lines 647 and 664. Skodak seems to be have the last one to modify this so perhaps it could be assigned to him.

          Dan Poltawski added a comment -

          This was fixed earlier today as per MDL-8528. Thanks for report


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: