Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8658

Odd Forum mail behavior. Users can edit postings after they are sent

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.7.1
    • Fix Version/s: 1.8
    • Component/s: Forum
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      I am experiencing the following problem with 1.7.1 installed from the build of 8 February 2007

      Any user, when viewing their own posting is presented with the choice of "edit" as well as "reply" and "delete" even after the posting has been sent. (The special setting allowing admins to always edit postings it NOT set to "true". )

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            Please file separate bugs for separate issues, it makes them easier to manage later. Thanks.

            I'll open a new one for the second issue.

            dougiamas Martin Dougiamas added a comment -

            (Other issue moved to MDL-8678)

            Hi, Yu, can you look at this one? It seems to be a role permissions issue.

            lazyfish Yu Zhang added a comment -

            Hi could you make sure that your students don't have mod/forum:editanypost capability? This capability actually allows them to edit any post any time.

            michaelp Michael Penney added a comment -

            Hi, if this can be set/unset on a role basis, I'd say it is a feature not a bug (as long as it can be turned off), being able to enable students in a particular forum to delete/edit forum posts at any time is a highly requested feature from our faculty.

            trobb Thomas Robb added a comment -

            It seems that someone (not me!) had given students additional privileges at the forum level that had resulted in the reported behavior. Sorry: "not a bug".

            lazyfish Yu Zhang added a comment -

            Cheers Tom. Closing.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  31/Mar/07