Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8677

IE 7 error when clicking on rtsp:// linked Real Media files

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7, 1.9, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6
    • Fix Version/s: 1.9.7, 1.9.8, 2.0, 2.1
    • Component/s: Resource
    • Labels:
      None

      Description

      We recently upgraded to Moodle 1.7, and also IE version 7.

      With moodle 1.6 and IE 6 , video files for example (rtsp://rajacademy.org/rajacademy/dilruba/101/common/tuning_dilruba.rm) would automatically start Real Player.

      Now, I get a " Internet Explorer cannot display the webpage" message with IE.

      Things work fine with Firefox, and real player starts playing the file.

      To create this scenario please visit http://www.kitchenorganica.com/moodle/ and log in using "tester" as username and password. Go into the Free Demo course and then click on any video link in Dilruba 101 - Week 1

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              Hide
              dougiamas Martin Dougiamas added a comment -

              I think Yu probably just fixed this in 1.8 already ... Yu?

              Show
              dougiamas Martin Dougiamas added a comment - I think Yu probably just fixed this in 1.8 already ... Yu?
              Hide
              adamann2 Ann Adamcik added a comment -

              We're seeing the same issue on 1.8+, updated from cvs on 5/12.

              Show
              adamann2 Ann Adamcik added a comment - We're seeing the same issue on 1.8+, updated from cvs on 5/12.
              Hide
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Moving to Dongsheng Cai... can you plz, check how this is going under 1.8... if ok, close as fixed, else... try to research why it isn't working under IE.

              Show
              stronk7 Eloy Lafuente (stronk7) added a comment - Moving to Dongsheng Cai... can you plz, check how this is going under 1.8... if ok, close as fixed, else... try to research why it isn't working under IE.
              Hide
              scyrma Mathieu Petit-Clair added a comment -

              Dongsheng and me have been testing this .. and I can't reproduce the problem (it works for me under Windows XP/IE7, in both Moodle 1.7 and 1.9) : when the link given is put in a ressource, Real Player starts automatically.

              Please note that the file that the link points to does not exist on the server, maybe that's where the problem comes from?

              We'll close this for now, please reopen if issue is still there...

              Show
              scyrma Mathieu Petit-Clair added a comment - Dongsheng and me have been testing this .. and I can't reproduce the problem (it works for me under Windows XP/IE7, in both Moodle 1.7 and 1.9) : when the link given is put in a ressource, Real Player starts automatically. Please note that the file that the link points to does not exist on the server, maybe that's where the problem comes from? We'll close this for now, please reopen if issue is still there...
              Hide
              nrparmar Nitin Parmar added a comment -

              This issue still seems to exist in Moodle 1.9.5.

              The rtsp:// file is linked to as Resource ('Link to a file or web site'), but then doesn't open when clicked, and displays "Internet Explorer cannot display the webpage" type messages in both IE7 and IE8.

              The link works fine in Firefox, and RealPlayer opens as expected.

              Show
              nrparmar Nitin Parmar added a comment - This issue still seems to exist in Moodle 1.9.5. The rtsp:// file is linked to as Resource ('Link to a file or web site'), but then doesn't open when clicked, and displays "Internet Explorer cannot display the webpage" type messages in both IE7 and IE8. The link works fine in Firefox, and RealPlayer opens as expected.
              Hide
              tsala Helen Foster added a comment -

              Nitin, thanks for your feedback. Reopening for further investigation...

              Show
              tsala Helen Foster added a comment - Nitin, thanks for your feedback. Reopening for further investigation...
              Hide
              nrparmar Nitin Parmar added a comment -

              Thanks Helen. The related discussion forum post can be found at: http://moodle.org/mod/forum/discuss.php?d=65698

              Show
              nrparmar Nitin Parmar added a comment - Thanks Helen. The related discussion forum post can be found at: http://moodle.org/mod/forum/discuss.php?d=65698
              Hide
              dongsheng Dongsheng Cai added a comment -

              the mimetype name in filelib.php changed, but the mimetype in resource module haven't been updated

              Show
              dongsheng Dongsheng Cai added a comment - the mimetype name in filelib.php changed, but the mimetype in resource module haven't been updated
              Hide
              dongsheng Dongsheng Cai added a comment -

              please test, feel free to reopen if you find any problem

              Show
              dongsheng Dongsheng Cai added a comment - please test, feel free to reopen if you find any problem

                People

                • Votes:
                  2 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Nov/09