Moodle
  1. Moodle
  2. MDL-8677

IE 7 error when clicking on rtsp:// linked Real Media files

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7, 1.9, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6
    • Fix Version/s: 1.9.7, 1.9.8, 2.0, 2.1
    • Component/s: Resource
    • Labels:
      None
    • Rank:
      15084

      Description

      We recently upgraded to Moodle 1.7, and also IE version 7.

      With moodle 1.6 and IE 6 , video files for example (rtsp://rajacademy.org/rajacademy/dilruba/101/common/tuning_dilruba.rm) would automatically start Real Player.

      Now, I get a " Internet Explorer cannot display the webpage" message with IE.

      Things work fine with Firefox, and real player starts playing the file.

      To create this scenario please visit http://www.kitchenorganica.com/moodle/ and log in using "tester" as username and password. Go into the Free Demo course and then click on any video link in Dilruba 101 - Week 1

        Issue Links

          Activity

          raja pooni created issue -
          Hide
          Martin Dougiamas added a comment -

          I think Yu probably just fixed this in 1.8 already ... Yu?

          Show
          Martin Dougiamas added a comment - I think Yu probably just fixed this in 1.8 already ... Yu?
          Martin Dougiamas made changes -
          Field Original Value New Value
          Assignee Petr ?koda [ skodak ] Yu Zhang [ lazyfish ]
          Hide
          Ann Adamcik added a comment -

          We're seeing the same issue on 1.8+, updated from cvs on 5/12.

          Show
          Ann Adamcik added a comment - We're seeing the same issue on 1.8+, updated from cvs on 5/12.
          Eloy Lafuente (stronk7) made changes -
          Assignee Yu Zhang [ lazyfish ] Dongsheng Cai [ dongsheng ]
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Moving to Dongsheng Cai... can you plz, check how this is going under 1.8... if ok, close as fixed, else... try to research why it isn't working under IE.

          Show
          Eloy Lafuente (stronk7) added a comment - Moving to Dongsheng Cai... can you plz, check how this is going under 1.8... if ok, close as fixed, else... try to research why it isn't working under IE.
          Hide
          Mathieu Petit-Clair added a comment -

          Dongsheng and me have been testing this .. and I can't reproduce the problem (it works for me under Windows XP/IE7, in both Moodle 1.7 and 1.9) : when the link given is put in a ressource, Real Player starts automatically.

          Please note that the file that the link points to does not exist on the server, maybe that's where the problem comes from?

          We'll close this for now, please reopen if issue is still there...

          Show
          Mathieu Petit-Clair added a comment - Dongsheng and me have been testing this .. and I can't reproduce the problem (it works for me under Windows XP/IE7, in both Moodle 1.7 and 1.9) : when the link given is put in a ressource, Real Player starts automatically. Please note that the file that the link points to does not exist on the server, maybe that's where the problem comes from? We'll close this for now, please reopen if issue is still there...
          Dongsheng Cai made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Mathieu Petit-Clair made changes -
          Link This issue has a non-specific relationship to MDL-13743 [ MDL-13743 ]
          Hide
          Nitin Parmar added a comment -

          This issue still seems to exist in Moodle 1.9.5.

          The rtsp:// file is linked to as Resource ('Link to a file or web site'), but then doesn't open when clicked, and displays "Internet Explorer cannot display the webpage" type messages in both IE7 and IE8.

          The link works fine in Firefox, and RealPlayer opens as expected.

          Show
          Nitin Parmar added a comment - This issue still seems to exist in Moodle 1.9.5. The rtsp:// file is linked to as Resource ('Link to a file or web site'), but then doesn't open when clicked, and displays "Internet Explorer cannot display the webpage" type messages in both IE7 and IE8. The link works fine in Firefox, and RealPlayer opens as expected.
          Hide
          Helen Foster added a comment -

          Nitin, thanks for your feedback. Reopening for further investigation...

          Show
          Helen Foster added a comment - Nitin, thanks for your feedback. Reopening for further investigation...
          Helen Foster made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Hide
          Nitin Parmar added a comment -

          Thanks Helen. The related discussion forum post can be found at: http://moodle.org/mod/forum/discuss.php?d=65698

          Show
          Nitin Parmar added a comment - Thanks Helen. The related discussion forum post can be found at: http://moodle.org/mod/forum/discuss.php?d=65698
          Dongsheng Cai made changes -
          Fix Version/s 1.9.7 [ 10360 ]
          Fix Version/s 1.9.8 [ 10400 ]
          Fix Version/s 2.0 [ 10122 ]
          Fix Version/s 2.1 [ 10370 ]
          Affects Version/s 1.9.6 [ 10340 ]
          Affects Version/s 1.9.5 [ 10320 ]
          Affects Version/s 1.9.4 [ 10300 ]
          Affects Version/s 1.9.3 [ 10290 ]
          Affects Version/s 1.9.2 [ 10280 ]
          Affects Version/s 1.9.1 [ 10240 ]
          Affects Version/s 1.9 [ 10190 ]
          Hide
          Dongsheng Cai added a comment -

          the mimetype name in filelib.php changed, but the mimetype in resource module haven't been updated

          Show
          Dongsheng Cai added a comment - the mimetype name in filelib.php changed, but the mimetype in resource module haven't been updated
          Hide
          Dongsheng Cai added a comment -

          please test, feel free to reopen if you find any problem

          Show
          Dongsheng Cai added a comment - please test, feel free to reopen if you find any problem
          Dongsheng Cai made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Martin Dougiamas made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          QA Assignee nobody
          Martin Dougiamas made changes -
          Workflow jira [ 19628 ] MDL Workflow [ 55151 ]
          Martin Dougiamas made changes -
          Workflow MDL Workflow [ 55151 ] MDL Full Workflow [ 84255 ]

            People

            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: