Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8679

Site administrator sees all events on the front page calendar with the "adminseesall" setting off

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7.1
    • Fix Version/s: 1.7.2, 1.8
    • Component/s: Calendar
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      I have adminseesall = off (admins are treated as regular students) setting in the calendar in 1.6. After an upgrade to 1.7.1+ admins see all course events on the front page calendar. This makes the front page quite slow to load on large sites. This is a bug because the defaults in 1.7 should try to mimic those set in 1.6.

        Gliffy Diagrams

          Attachments

            Activity

            samulik Samuli Karevaara added a comment -

            Just adding: in my 1.7.1+ the "Admins See All" setting is also unchecked/off, still all of the events are showing...

            pj Jon Papaioannou added a comment -

            Samuli, I believe I fixed this yesterday in calendar/lib.php 1.151.2.4 (for MOODLE_17_STABLE). Can you confirm?

            pj Jon Papaioannou added a comment -

            Fix confirmed.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  30/Mar/07