Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8853

Forcing language to en_us at course level breaks links to help files

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7, 1.7.1, 1.7.2, 1.7.3, 1.8, 1.8.1, 1.8.2, 1.8.3
    • Fix Version/s: 1.7.4, 1.8.4, 1.9, 2.0
    • Component/s: Documentation
    • Labels:
      None
    • Environment:
      OS X 10.4.8
      mysql 5.0.27
      php 5.2.1
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      0. Install English en_us package
      1. Set default language to en_us for site
      2. Force language to en_us at course level

      Afterwards links to help files (via ? icon) are broken. Set Force language option to anything else (en or nothing) yields good links

      A link when force language is set to en_us looks like this:
      http://ourmoodlesite/moodle/help.php?module=moodle&file=search.html&forcelang=en_us_utf8
      which reports "Help file "search.html" could not be found!" even though the link to the index of all help files in this window works fine.

      The same link with force language set to en and nothing respectively, look like:
      http://ourmoodlesite/moodle/help.php?module=moodle&file=search.html&forcelang=en_utf8
      http://ourmoodlesite/moodle/help.php?module=moodle&file=search.html&forcelang=
      both of these work.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Jan/08