Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-8865

unable to post in forums after upgrade to php 5.2.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.6.1
    • Fix Version/s: 1.6.6
    • Component/s: Forum
    • Labels:
      None
    • Environment:
      Solaris 9 Sparc
      apache 1.3.37
      php 5.2.1
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE

      Description

      Hi,

      Once I upgraded to php 5.2.1 moodle showed a blank page when I try to post to forums. The problem exists in php 5.2.0 also. I downgraded to php 5.1.6 and posting was restored. I am seeing the following warning in the php log:

      [12-Mar-2007 11:51:27] PHP Warning: Invalid argument supplied for foreach() in /home/scope/moodle/mod/forum/discuss.php on line 333

      Danny

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              nicolasconnault Nicolas Connault
              Reporter:
              dannylee@sfu.ca Danny Lee
              Tester:
              Nobody
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Jan/08