Moodle
  1. Moodle
  2. MDL-8883

Moodle -> Modules -> Filters -> Tex Notation Settings forcing double slashes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.1
    • Fix Version/s: 1.7.2, 1.8, 1.9
    • Component/s: Maths filters
    • Labels:
      None
    • Environment:
      REHL, Moodle 1.7.1 (2006101010), PHP Version 5.1.6, MySQL 5.0.24
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE
    • Rank:
      29003

      Description

      Tex Filter was working perfectly. It was set up with a previous version (1.6.3). After trying to add to the preamble, Moodle is forcing double slashes and therefore the Tex Filter is now processing the preamble. If you hit "Reset to defaults", I get the single slash back but "Save changes" will again force double slashes.

      For background, I had the /usepackage[safe]

      {tipa}

      added to the preamble before and it was working perfectly. Today I wanted to add the package 'parsetree' to see how it would perform and ran into this issue.

        Activity

        Hide
        Petr Škoda added a comment -

        fixed in cvs, thanks for the report!

        Show
        Petr Škoda added a comment - fixed in cvs, thanks for the report!

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: