Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9052

Small inconsitency when accesing to forums from emails...

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.7.2, 1.8
    • Component/s: Forum
    • Labels:
      None
    • Environment:
      Any
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE

      Description

      I was going to reply one message to one forum, when I detected that behaviour of different links present in the forum email was pretty different:

      1) All the present links (course title, discussion title, message title, show parent and see this in context) redirect me automatically to the login page.

      2) BUT the "reply" link send me to one page with "Sorry, guests are not allowed to post. Would you like to log in now with a full user account?". And I'm able to see, in that page, the course name, the forum name and the discussion name.

      Not critical but an exposure of information!

      Reproduced under 1.8. +1 to fix it on 1.7 if present there too.

        Attachments

          Activity

            People

            Assignee:
            dougiamas Martin Dougiamas
            Reporter:
            stronk7 Eloy Lafuente (stronk7)
            Tester:
            Nobody
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              30/Mar/07