Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8
    • Component/s: Course
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      when you turn editing on for a course, and then do "something" eg add a resource/activity, go somewhere else - when you return to the course homepage, editing has been turned off....

      using latest 1.8 from cvs, configured to use dbsessions - will try to post more info soon!

      Dan

        Gliffy Diagrams

          Activity

          Hide
          danmarsden Dan Marsden added a comment -

          seems to be a problem when using dbsessions - works fine when sessions saved to disk.....

          Show
          danmarsden Dan Marsden added a comment - seems to be a problem when using dbsessions - works fine when sessions saved to disk.....
          Hide
          danmarsden Dan Marsden added a comment -

          ah - looks like I missed part of the problem - this is displayed at the bottom of every page (missed it because it was under my footer!

          "Session Replace: MySQL server has gone away"

          which I'm guessing is the error given when it trys to save the session!

          Show
          danmarsden Dan Marsden added a comment - ah - looks like I missed part of the problem - this is displayed at the bottom of every page (missed it because it was under my footer! "Session Replace: MySQL server has gone away" which I'm guessing is the error given when it trys to save the session!
          Hide
          danmarsden Dan Marsden added a comment -

          adding Petr - were you working on dbsessions?

          Dan

          Show
          danmarsden Dan Marsden added a comment - adding Petr - were you working on dbsessions? Dan
          Hide
          skodak Petr Skoda added a comment -

          Hmm, never saw this error

          Show
          skodak Petr Skoda added a comment - Hmm, never saw this error
          Hide
          danmarsden Dan Marsden added a comment -

          this looks like it has been fixed - possibly as a result of MDL-9172 ?

          Dan

          Show
          danmarsden Dan Marsden added a comment - this looks like it has been fixed - possibly as a result of MDL-9172 ? Dan
          Hide
          danmarsden Dan Marsden added a comment -

          ...no it hasn't - whoops!- testing the wrong site!

          Dan

          Show
          danmarsden Dan Marsden added a comment - ...no it hasn't - whoops!- testing the wrong site! Dan
          Hide
          danmarsden Dan Marsden added a comment -

          looks like this bug also means you can't turn editing "on" for the site homepage - to test - change to use dbsessions, then try to turn editing on on the site homepage - clicking the button refreshes the page, but does not turn it on!

          Dan

          Show
          danmarsden Dan Marsden added a comment - looks like this bug also means you can't turn editing "on" for the site homepage - to test - change to use dbsessions, then try to turn editing on on the site homepage - clicking the button refreshes the page, but does not turn it on! Dan
          Hide
          danmarsden Dan Marsden added a comment -

          fixed ages back. - closing.

          Show
          danmarsden Dan Marsden added a comment - fixed ages back. - closing.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                31/Mar/07