Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9165

Missing blog access for admins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.1
    • Fix Version/s: 1.7.3, 1.8.1, 1.9
    • Component/s: Accessibility
    • Labels:
      None
    • Environment:
      Linux, mySQL, Moodle 1.71
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      Blog setting "users can only read and access their own blogs" results in the fact that neither teachers nor admins can access the blogs.

      Admin sees the blog log including the first few words (see first attachment), but the link leads to an empty page. "Log in as" results in the same empty page (see second attachment).

      In my environment, even changing the setting to "public" does not reveal the previous entries.

      URL and password can be provided - but not that publicly

        Attachments

          Activity

            People

            Assignee:
            lazyfish Yu Zhang
            Reporter:
            ikasawak Sandra Reitz
            Tester:
            Nobody
            Participants:
            Component watchers:
            Andrew Nicols, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              11/Jun/07