Moodle
  1. Moodle
  2. MDL-9204

uploaded assignment files not visible to teacher on grading page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.5, 1.7.2, 1.8
    • Fix Version/s: 1.6.6, 1.7.3, 1.8.1, 1.9
    • Component/s: Assignment (2.2)
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE, MOODLE_18_STABLE, MOODLE_19_STABLE
    • Rank:
      29640

      Description

      After upgrading to version 1.8 (just updated to latest as of last evening, 3.april, in case a fix was already there),
      uploaded assignments (using upload single file option) are not showing where they need to -

      with some uploads present, the

      "view 0 submitted assignments" link still reads 0;

      on the Assignment > Submissions page, the uploaded files do not show up in the "Last Modified (student)" space

      However, if the "Grade" link is clicked to open up the grading window, the link to the uploaded file does appear in that window, and the file can be opened from here.

      (all had been working fine with version 1.7+, prior to upgrading to 1.8)

        Activity

        Nicolas Connault added a comment -

        The problem is that 'timemodified' doesn't get updated when the assignment is uploaded by the student.

        Nicolas Connault added a comment -

        I found that the code was nearly identical in all three versions (1.6, 1.7 and 1.8), each time neglecting to give the new submission a timemodified value. This may not be a big issue in earlier versions, perhaps because no SQL depends on that value being set. It is a bug nevertheless, so I'm fixing it in all versions.

        Nicolas Connault added a comment -

        Fixed in all versions 1.6+


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: