Moodle
  1. Moodle
  2. MDL-9209

CLONE -SCORM packages are not being upgraded properly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8.1, 1.9
    • Component/s: SCORM
    • Labels:
      None
    • Environment:
      Moodle.org under 1.8
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      The packages in the Features Demo were all broken after I upgraded to 1.8.

      I had to reload the packages completely to make them work, but then I lost all the grades from before ....

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Brian Schmidt added a comment -

            I am having this same issue. After upgrading to 1.8, mine broke as well. The message I get back is:

            "Data required to connect to a learning management system is missing. Without such a connection, this lesson cannot continue. Contact your learning management system administrator for help."

            There seem to be more SCORM tables in 1.8 than 1.7.x – is this why? Am I going to now have to reload every one of these packages to fix this?

            Show
            Brian Schmidt added a comment - I am having this same issue. After upgrading to 1.8, mine broke as well. The message I get back is: "Data required to connect to a learning management system is missing. Without such a connection, this lesson cannot continue. Contact your learning management system administrator for help." There seem to be more SCORM tables in 1.8 than 1.7.x – is this why? Am I going to now have to reload every one of these packages to fix this?
            Hide
            Brian Schmidt added a comment -

            Well, it seems I can't even reload them now. All of a sudden, these courses which have worked very well in the last several major Moodle releases won't run at all now. I always receive this error. This is pretty major.

            Show
            Brian Schmidt added a comment - Well, it seems I can't even reload them now. All of a sudden, these courses which have worked very well in the last several major Moodle releases won't run at all now. I always receive this error. This is pretty major.
            Hide
            Martin Dougiamas added a comment -

            This needs to be a priority for the SCORM guys.

            Show
            Martin Dougiamas added a comment - This needs to be a priority for the SCORM guys.
            Hide
            Jesús Rincón added a comment -

            This a problem with upgrade.php.

            We will work in it.

            Show
            Jesús Rincón added a comment - This a problem with upgrade.php. We will work in it.
            Hide
            Jesús Rincón added a comment -

            We have already resolved this issue. Now, when you update your version from Moodle 1.7 to Moodle 1.8, you can access to your scorm packages from your 1.7 version and go through every sco in it.

            Show
            Jesús Rincón added a comment - We have already resolved this issue. Now, when you update your version from Moodle 1.7 to Moodle 1.8, you can access to your scorm packages from your 1.7 version and go through every sco in it.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: