Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9235

bad html produced when moving modules within a course

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8.1
    • Component/s: Course
    • Labels:
      None
    • Environment:
      firefox 2.0, windows 2000, apache 2.2, php 5.2.2, mysql 5.0.18
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      XML parsing error when moving a module within a course. Problem caused by misbalanced <li> when breaking out of a code loop. Code in course/lib.php at 1346:

      echo '<li class="activity '.$mod->modname.'" id="module-'.$modnumber.'">'; // Unique ID
      if ($ismoving)

      { if ($mod->id == $USER->activitycopy) continue; }

      changed to include </li> before continue stmt:

      echo '<li class="activity '.$mod->modname.'" id="module-'.$modnumber.'">'; // Unique ID
      if ($ismoving) {
      if ($mod->id == $USER->activitycopy)

      { echo '</li>'; // needed to close <li> above continue; }

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda added a comment -

            fixed in 1.8, was already fixed in HEAD
            thanks for the report and patch


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jun/07