Moodle
  1. Moodle
  2. MDL-9263

1.8 Installation hangs on "setting up module tables" with no continue button

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a bug
    • Affects Version/s: 1.8
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      described in Description section
    • Rank:
      9041

      Description

      Everything I've discribed on the forum in this thread, w/o answer so far. Please help me, I completely stucked and don't know what to do next with this installation. VIDE: http://moodle.org/mod/forum/discuss.php?d=68677

      (I'm also pasting the text from this thread
      ============
      I stucked during installation of Moodle 1.8 version (http://download.moodle.org/download.php/stable18/moodle-latest-18.zip), just downloaded and uploaded on my webhost.

      It's hanging on "setting up module tables", to be detailed, on "lams" table. It says that there are no warnings, "scroll to the continue button" but w/o continue button. After refreshing that page or just reentering moodle, it goes to /moodle/admin/index.php and it's just blank. In MySQL I see it is creating 102 tables with 771 records, 229,1 Kb EVERY TIME.

      It's webhost (Linux one) so I don't have any access to php.ini and other files.

      I've tried so far:

      "My solutions" - i.e. - what I think can help:

      • http://docs.moodle.org/en/Installing_Moodle#Requirements - "Notes: For Moodle 1.6 or later, If you use latin languages only you can use MySQL 4.1.12." (ONLY THIS 4.1.12 version?)
      • "The setting memory_limit to be at least 16M (32M is recommended for Moodle 1.7 or later)." - phpinfo says it's 16M...
      • /session.save_handler set to files, safe mode off... IT'S OK!/

      So... How many tables there are in full database of installed moodle? (James McCormack wrote on http://moodle.org/mod/forum/discuss.php?d=64615 that he had 118 before the hang, quite better result than mine ;P)

      My admin suggested to do "hand installation" simply by phpmyadmin. How to do it? Is it possible? I haven't found any .sql file in moodle directories to upload...

      I'm impatiently waiting for answer

      regards and Happy Easter!
      Lion

      PS. I haven't tried 1.7 or other Moodle version. As I see 1.8 is a very new one so maybe it's because of it?

        Issue Links

          Activity

          Petr Škoda added a comment -

          Please add
          $CFG->debug=2047;
          $CFG->debugdisplay=1;
          to your config.php, then empty database and retry the installation. You might get some error messages indicating source of the problem.

          Artur Lewandowski added a comment -

          I'm sorry for long delay but I was "fighting" with that 1.8+ version installation...

          First of all I'd like to thank You for that debug information to add to config.php file. It revealed the most important thing:

          Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 184320 bytes) in /[cut]/elearning/html/moodle/lib/soap/nusoap.php on line 5346

          I have written to my admins asking for a temporary "lift" of that 16 Mb limit.

          Yes, it was expanded to 25 Mb and of course the installation went further than with 16 Mb. It added this time 185 not 102 tables in MySQL database but... blank page appeared and then another one suprise:

          Fatal error: Allowed memory size of 26214400 bytes exhausted (tried to
          allocate 40 bytes) in /[cut]/elearning/html/moodle/
          admin/mnet/MethodTable.php on line 77

          Unfortunately my admins did not allow me to expand this PHP memory limit. Buying dedicated server for moodle is not possible so...

          I HAD TO RESIGN FROM THIS SCRIPT.

          It's too "memory eating"...


          TODAY I've tried with last stable version of 1.7+ and... I managed to install it and it... WORKS!


          (MY) SUMMARY:

          • version 1.8+ - Sorry to say but in my opinion this version is like car which cannot be tanked. Good-looking but You are not able to drive it. So why to have this car? Even if You cannot START it... Ver 1.8 is not reliable... Sorry, I don't have F-16 to handle it ;(
          • version 1.7+ - it's working and maybe I'll use it... Unfortunately older version... But I think I won't upgrade it to 1.8 in next "100 years".

          ====
          The same message was sent on Moodle.org's Instalation problems' forum:
          http://moodle.org/mod/forum/discuss.php?d=68677

          Petr Škoda added a comment -

          The problem is that Moodle is not designed to run on shared hosting servers - the major problems are memory consumption and safe mode. 1.8 does more caching to speed up processing which takes some more memory.

          Artur Lewandowski added a comment -

          Petr, unfortunately it's still open, because 1.8+ version was not installed. But we know now why - 25 Mb of PHP memory is not enough. It should be changed in http://docs.moodle.org/en/Installing_Moodle#Requirements:

          "Notes: For Moodle 1.6 or later, If you use latin languages only you can use MySQL 4.1.12." (ONLY THIS 4.1.12 version?)

          • "The setting memory_limit to be at least 16M (32M is recommended for Moodle 1.7 or later)."

          It's not true as we can se above on this "good example".

          Better:
          "at least 32M", not 16... for 1.8+
          at least 16M (maybe?) for 1.7, then recommended 32 for this version I think, but... 1.8 - at least 32 as I see...

          Artur Lewandowski added a comment -

          I'm sorry for "it's still open", I've written it seeing only "Change by Petr ?koda [15/Apr/07 02:38 AM]" (in progress => open)

          It should be written more detailed in Requirments about a BIG diffrence between 1.7 and 1.8 versions. As You have written - "is not designed to run on shared hosting servers". Maybe it concerns mostly 1.8 as You said but I think 1.7 is capable for less "powerful" servers...

          Petr Škoda added a comment -

          What PHP version are you using? There was a significant change in 5.2.x - you have to multiply required memory settings by 1.5-2.
          I am going to fix the docs tomorrow. Thanks!

          Artur Lewandowski added a comment -

          Unfortunately it's 5.2.0 version. But I'm also able to use PHP 4 (I don't remember the version... oh... sorry, it's noted in the first post here: 4.4.4.

          Duh... multiply memory settings by 1.5-2. But I was using (as I described above) both MySQL 4 and 5 and both PHP 4 and 5 in all 4 combinations. Everytime it stopped in the same place (i.e. as described, 102 tables, on the lams table etc.).

          So 4.4.4. PHP with 16M and 1.8+ moodle also do not working with...

          Artur Lewandowski added a comment -

          I'm sorry for being not so polite this time ;P

          Of course I'm thankful for Your help and comments.

          BTW... $CFG->debug=2047; What does 2047 number stands for? Some specific place in moodle instalation to display error?

          Petr Škoda added a comment -

          The 2047 is normal PHP debug level for all errors without PHP5 strict.

          The official required memory is now 40M, I hope I have updated all places - see MDL-9363

          Artur Lewandowski added a comment -

          Hehe... from default 8M, with minimum 16M and recommended 32M up to 40M recomended and 192M mentioned... WOW!

          I'm impressed but... and also You wrote about installer.php checking this limit - it will finish all topics about that installation problems

          So... unfortunately I will be using 1.7+ version ;|

          Thank for Your help and hehe this:
          http://docs.moodle.org/en/index.php?title=Installing_Moodle&diff=22391&oldid=22385

          BTW... 1.8 requires 40 up to 192... 1.9 will... and 2.0 will? Is there some limit? Moodle 3.0 will require 1G? Hehe... Good luck!
          Those requirments are shrinkening the number of potential users ;/

          Petr Škoda added a comment -

          I would not laugh, you might run out of memory in cron sooner than expected I would recommend frequent backups, because it might cause data integrity problems. Also do not enable any "hungry" features such as stats and uninstall all modules that are not required...

          Artur Lewandowski added a comment -

          Moodle 1.6.5+ then?

          What to say... it's quite sad. So far new moodle 1.7.2 is installed and is working but... we'll see how it will work...

          Thanks for advices, I will remember of them. Backup is my second name, so in this field - don't worry about it

          BTW... Do You have some connections with some hosting company which is providing dedicated servers with 3-digit PHP memory_limit? It looks like this ))
          Ok, enough jokes...

          Thanks for everything Moodle has very good support division, gratz and good luck!

          Petr Škoda added a comment -

          You can try Moodle 1.1 if you wish low memory footprint with minimal feature set

          Artur Lewandowski added a comment -

          1.1 version? Maybe it's some kind of solution then

          Where are older version available?


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: