Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9363

update memory limit checks and docs

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8.1
    • Component/s: Documentation, Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      Moodle 1.8 does not install if memory limit is less than 40M in PHP 5.2.0; previous versions of PHP require less memory because the used memory calculation is wrong.

      To do:
      1/ fix installation docs
      2/ fix checked limits in installer

      This fix should prevent frequent incomplete install reports caused by running out of memory.

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda created issue -
            skodak Petr Skoda made changes -
            Field Original Value New Value
            Description Moodle 1.8 does not install if memory limit is less than 40M in PHP 5.2.0; previous versions of PHP require less memory because the used memory calculation is wrong.

            To do:
            1/ fix installation docs
            2/ fix checked limits in installer
            Moodle 1.8 does not install if memory limit is less than 40M in PHP 5.2.0; previous versions of PHP require less memory because the used memory calculation is wrong.

            To do:
            1/ fix installation docs
            2/ fix checked limits in installer

            This fix should prevent frequent incomplete install reports caused by running out of memory.
            Priority Minor [ 4 ] Critical [ 2 ]
            skodak Petr Skoda made changes -
            Summary update memory limit checks update memory limit checks and docs
            skodak Petr Skoda made changes -
            Priority Critical [ 2 ] Major [ 3 ]
            skodak Petr Skoda made changes -
            Component/s Documentation [ 10073 ]
            Component/s Installation [ 10069 ]
            Component/s Administration [ 10050 ]
            skodak Petr Skoda added a comment -

            fixed in moodle and langs, closing...
            the change in installer will be visible after next installer.php update

            skodak Petr Skoda made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            skodak Petr Skoda added a comment -

            Official min limit is 40M now. It may work with lower memory settings but even 40M may not be always enough. Normal Moodle pages try to increate the memory to 96M, cron and other scripts to 192M.

            Please note that code is tested mostly with the higher memory settings, not with enforced 40M limit.

            daniss Daniele Cordella added a comment -

            Ciao Petr
            I had the same problem you described. I had incomplete install caused by running out of memory on Moodle 2.0 and moodle didn't risw up any warning. Maybe this check should be improved!!!!

            daniss Daniele Cordella added a comment -
            dougiamas Martin Dougiamas made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            QA Assignee nobody
            dougiamas Martin Dougiamas made changes -
            Workflow jira [ 20364 ] MDL Workflow [ 55726 ]
            dougiamas Martin Dougiamas made changes -
            Workflow MDL Workflow [ 55726 ] MDL Full Workflow [ 84843 ]

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jun/07