Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-945

Multiple correct answers in feedback are shown incorrectly for short-answer (& numerical) questi

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 1.7
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      All
    • Database:
      Any
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_17_STABLE

      Description

      For short-answer questions and numerical questions:

      If any answer that gives between 0% and 100% appears before the correct answers, then at least one of these will be shown among the correct answers in feedback.

      Another issue is that only the first of the correct answers (awarded 100%) will be shown.

        Gliffy Diagrams

          Activity

          Hide
          dougiamas Martin Dougiamas added a comment -

          From Henrik Kaipe (kaipe at users.sourceforge.net) Thursday, 1 January 2004, 11:07 PM:

          With version 1.116 of quiz/lib.php

          this problem is eliminated for the short-answer case.

          There is still a need to tackle this for numerical questions.

          From Eloy Lafuente (stronk7 at moodle.org) Sunday, 21 March 2004, 08:36 AM:

          Old bug. It was unassigned so I assign it to you, Martin...

          Show
          dougiamas Martin Dougiamas added a comment - From Henrik Kaipe (kaipe at users.sourceforge.net) Thursday, 1 January 2004, 11:07 PM: With version 1.116 of quiz/lib.php this problem is eliminated for the short-answer case. There is still a need to tackle this for numerical questions. From Eloy Lafuente (stronk7 at moodle.org) Sunday, 21 March 2004, 08:36 AM: Old bug. It was unassigned so I assign it to you, Martin...
          Hide
          timhunt Tim Hunt added a comment -

          This got fixed during my work on the numerical question type between Moodle 1.6 and 1.7.

          Show
          timhunt Tim Hunt added a comment - This got fixed during my work on the numerical question type between Moodle 1.6 and 1.7.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                7/Nov/06