Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-9471

Fatal error encountered whilst testing Reset: Call to undefined function groups_remove_all_group_members.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.9, 2.0
    • Component/s: Administration
    • Labels:
      None
    • Environment:
      Win2003, IIS, MSSQL
    • Database:
      Microsoft SQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      Screenshot of error message attached. Appears to remove all student details from the course (e.g. blog entries viewable in the course)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              cplegg Chris Legg created issue -
              angrycat Jeremy Hopkins added a comment -

              I have the same error running the latest stable release of 25/05/07 running Suse Linux / PHP 4.3.10 / MySQL 4.1.20

              katpot Katarzyna Potocka added a comment -

              I had the same problem with 1.8.1 and while searching for the function groups_remove_all_group_members I noticed, that this function has no functionality at all. The group members are being deleted during the role_unassign process, so, in my opinion, this call to the function groups_remove_all_group_members i unnecessary.

              trogdor Julian Ridden added a comment -

              Have just had this in a training course with 1.8.2. Is thi8s stopping reset from occuring. Is it fixed yet or part of the bugathon?

              skodak Petr Skoda made changes -
              Field Original Value New Value
              Link This issue has a non-specific relationship to MDL-7028 [ MDL-7028 ]
              mentis Alex Djachenko added a comment -

              Version 1.8.3
              He same error. There is clean-up some courses.

              skodak Petr Skoda made changes -
              Assignee Martin Dougiamas [ dougiamas ] Petr Skoda [ skodak ]
              skodak Petr Skoda added a comment -

              fixed in cvs - see MDL-7028
              thanks for the report

              skodak Petr Skoda made changes -
              Status Open [ 1 ] Resolved [ 5 ]
              Fix Version/s 1.9 [ 10190 ]
              Fix Version/s 2.0 [ 10122 ]
              Resolution Fixed [ 1 ]
              oa_sychev Oleg Sychev added a comment -

              It will be very nice to have it fixed in 1.8. too.

              skodak Petr Skoda added a comment -

              The problem is that course reset never worked properly.
              Fixing just this problem will not solve it in 1.8.x, unfortunately I do not have a week to backport/test everything, the code in 1.9dev depends on features available only in that release, sorry

              dougiamas Martin Dougiamas made changes -
              Status Resolved [ 5 ] Closed [ 6 ]
              QA Assignee nobody
              dougiamas Martin Dougiamas made changes -
              Workflow jira [ 20481 ] MDL Workflow [ 55812 ]
              dougiamas Martin Dougiamas made changes -
              Workflow MDL Workflow [ 55812 ] MDL Full Workflow [ 84921 ]

                People

                • Votes:
                  3 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    3/Mar/08