Moodle
  1. Moodle
  2. MDL-9657

Allow resubmit after grading on "advanced uploading of files" assignment type

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.9
    • Component/s: Assignment (2.2)
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      29505

      Description

      The "advanced upload of files" assignment type does not permit re-submission after grading -
      once the assignment is either (1)submitted for grading, or (2)graded, even if left in draft,
      the upload form is no longer provided to the student.

      It would be helpful to provide an "allow re-submission of files" option.

      The other features of the "advanced upload of files" assignment type are quite welcome, but it is unfortunate that the resubmit option has been lost.

      1. assgn_5_HEAD.patch
        13 kB
        Petr Škoda
      2. assignment2_m18x.patch
        8 kB
        Petr Škoda

        Activity

        Samuli Karevaara added a comment -

        We would like to stick with "Advanced uploading of files" type, instead of advising to use the "older" way if teachers want resubmissions, so my vote for this too.

        Paul Nijbakker added a comment -

        In our version 1.8.2 we experience a problem that would be solved by adding a resubmission option to the Advanced uploading of files assignment type.

        Martin Dougiamas added a comment -

        I think that option may have been lost accidentally in a refactoring ... can you restore it please Petr?

        Petr Škoda added a comment -

        This works for me as expected, students can not edit/upload/delete if assignment graded or "submitted for grading". Teachers may remove the grade and/or reset it to draft.

        At present it is not possible to allow submissions after the grading, it would require major internal changes including new db fields - sorry.

        Martin Dougiamas added a comment -

        Petr, we need to do something for 1.9 and 1.8 here ... This regression has a lot of votes.

        How about we just make it so that UNTIL the due date has occurred then students can re-upload their files anytime? Right now student are prevented from re-uploading even when the due date has not been reached and the grade is "No grade".

        No new db fields required.

        Petr Škoda added a comment -

        working a some solution...

        Petr Škoda added a comment -

        I have committed patch into 1.9 and HEAD, please test it. The change is that draft state is not depending on grading. Teacher may change draft<->final state freely before the strict due date.

        no submission - draft - not graded == uploading allowed
        submission - draft - not graded == uploading allowed
        submission - draft - graded == uploading allowed

        final or after strict due date == uploading not allowed

        please test, if it does what ppl want, it can be backported into 1.8 too

        thanks for the report!

        Petr Škoda added a comment -

        sending patch against latest 1.8.x too

        Ray Lawrence added a comment -

        I may be missing something here but if the assignment is in draft mode how does the teacher know whether the student has finished compiling their submission?

        Isn't the issue that once an assignment has been submitted and graded it can't be returned to draft status by the teacher in order to allow resubmission?

        Petr Škoda added a comment -

        Please try latest 1.9dev or patch for latest 1.8.x, teacher may change now the draft status anytime before the strict due date.

        student finalizes submission before due date -> teacher grades it -> may decide to revert back to draft mode -> student reuploads -> teacher regrades and finalizes it -> teacher changes mind and reverts back to draft -> etc., ect.

        Martin Dougiamas added a comment -

        Watchers on this bug can you please check this does what you want and comment here? It will soon be set in "stone" for 1.9 and 1.8.

        Neil Streeter added a comment -

        Lauren and I (If I may speak on her behalf) would really like to see this option created and implemented exactly as it is in the 'Single file upload assignment'. I know that probably means a db schema change. I honestly think it would be the best way to resolve the issue. I also understand your reluctance to mess with the schema when 1.8 is stable.

        If the advanced assignment had this functionality wouldn't it be possible to eliminate the single file upload assignment type entirely? Just trying to point out a positive here Under the advanced assignment type the instructor could set 'Maximum number of uploaded files' to 'one' to replicate the single file upload assignment type. The only piece missing in the advanced assignment, AFAIK, is resubmission.

        The other thought I was having is to create the assignment type as an 'addon'/contrib to moodle 1.8... Either replacing or running along side the current 'Advanced file upload' type. It could then make it into 1.9 – hopefully.. I would think this has more possibility of becoming unruly in the long run.

        Thanks!
        Neil

        Petr Škoda added a comment -

        I do not agree with reverting because it does remove existing feature. Did you test the patch for 1.8x or code from 1.9?
        There are still some free fields left in assignment table, we could add more configuration options without changing db - I was thinking about adding option to disable the drafts/finalized submissions tracking.

        Advanced uploading sort of replaces all other types because you can submit notes or files or nothing in theory.

        No new plugin will make it into 1.9, sorry no time for that

        Neil Streeter added a comment -

        Hi Petr,

        Yes we tested the patch on 1.8 - I downloaded it from the top of this bug report and it applied cleanly.

        I like the fact that the instructor can turn the assignment back to 'draft' and allow that particular student to resubmit his/her assignment. That allows for very granular control in that the instructor decides and 'enables' the ability for the student to resubmit. Some of our instructors will certainly find that very nice. Others, however, will want to enable resubmission for the entire assignment all of the time so the _student_ can decide for themselves if they would like to resubmit. If they do, it goes back to 'submitted' status and the instructor essentially regrades. It really is just a difference in if the instructor has to enable resubmission once for the entire assignment or once for each student after each submission. I can see value in each method but I also know many instructors/teachers are used to the former method.

        I would be happy to provide more input if you like.

        Cheers,
        Neil

        James Ballard added a comment -

        New "revert to draft" with grade works well in 1.9.

        Should it be working on latest 1.8? I didn't apply patch just upgraded to latest daily build.

        Yours
        James

        Petr Škoda added a comment -

        not in 1.8.x - we need some testing and feedback first

        Ray Lawrence added a comment -

        Ok, it seems to be working as described above. A few observations;

        When the teacher makes the submission final the message to the student is still "Assignment was already submitted for marking and can not be updated". This is incorrect and potentially confusing to students. Suggest an additional string for teacher finalised submissions something like "No further submissions are allowed".

        Where the due date/time passes (WITH late submissions are not allowed) and the teacher clicks the "No more submissions" button the period of lateness is changed to reflect the time the button was clicked. If the submission is in draft mode then, arguably, the date/time of submission is the same as the due date for the activity - they can't submit late! So this needs to be reflected in the display - unless this is not regarded as a submission.

        When feedback is added and then a response file is uploaded the feedback is lost. (This has always been the case but I've not got around to logging a bug before).

        I like the suggestion for a global revert to draft / No more submissions button.

        All this is quite different to the current behaviour, IMO it shouldn't be in anything earlier than 1.8.5. Preferably 1.9 onwards.

        Petr Škoda added a comment - - edited

        I agree the language string needs clarification which disqualifies it from backporting. Unfortunately we do not know who "finalized" the submission, wwe will have to find some neutral message stating that submission is not allowed anymore + a different one when the due date is over.

        Any suggestions are appreciated, thanks for testing and any help!

        Petr Škoda added a comment -

        sending patch for problems mentioned above,
        the "lost grade/feedback" is known issue, unfortunately it can not be fixed without major rewrite of grading popup

        Petr Škoda added a comment -

        Draft tracking is now optional - new setting on modedit page
        Unfortunately the changes now are too big for 1.8.x backport (new lang strings, help files, UI and db storage).

        Please test and report any problems here, thanks everybody for valuable feedback and ideas...

        Ray Lawrence added a comment -

        Some feedback:

        New option seems to prohibit students submitting i.e. perpetual draft mode unless the option is set to yes. It works.

        New option "Disable email notifications: Is this student notifications? If so I suggest the following:

        A global option in the module settings page to control this. If set to to "No" possibly include the current option so that teachers have granular control of this.
        Change the label so that it's clear that the prevented emails are to "students" not teachers (I haven't come up with a proposal that would be useful for all potential role names.
        Submission specific switches to control suppression of emails also need to be present on the quick grading interface.

        Major issue: I'll post this as anew bug. Students can see response files before teachers has saved feedback/grade.

        Petr Škoda added a comment -

        1/ the email notification is bug MDL-6591 - in short: it can not be implemented as activity setting now because there is no room to store it in assignment table - to be fixed in 2.0

        2/ access to feedback files can not be solved now - needs file handling rewrite and db changes in assignment, to be fixed in 2.0

        3/ the language strings/help do need improvements - ideas and patches are welcome! - I am going to work on other bugs now, my English is not good enough for this

        Ray Lawrence added a comment -

        Ok, thanks.

        Have had some inspiration and have updated MDL-6591

        Petr Škoda added a comment -

        I have committed one more fix for handling of dates when reverting to draft and disabling submissions.

        Big thanks to everybody for ideas, cooperation and testing!

        Bruno Vernier added a comment -

        I miss the resubmit after grading button on "advanced uploading of files" in moodle 2.x

        even forcing the resubmit field to "1" in the database does nothing so the problem is that advanced uploading source code ignores the "resubmit" setting

        all other assignment types seem to allow resubmitting... why not the advanced assignment type?

        may we re-open this ticket?

        Bruno Vernier added a comment -

        I think the key is in the third stanza of the definition of the function is_finalized in
        mod/assignment/type/upload/assignment_class.php

        changing the third return function to return '' like the other 3 will cause moodle to allow all advanced assignments to accept re-submissions

        of course, ideally i think it should check for the assignment's resubmit field

        function is_finalized($submission) {
        if (!$this->drafts_tracked())

        { return ''; } else if (empty($submission)) { return ''; }

        else if ($submission->data2 == ASSIGNMENT_STATUS_SUBMITTED or $submission->data2 == ASSIGNMENT_STATUS_CLOSED)

        { return $submission->data2; }

        else

        { return ''; }

        }


          People

          • Votes:
            11 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: